Creating First Application User

I am Facing this error lots of times, I understand the question while answering it’s going an error guide me, please !!!
Screenshot (161)

Hi @B.Doondishwar_Kumar,

It looks like you are starting your mongod instance using command line options.

How did you start your mongod instance ?

The error message says : Non-existent data directory : /data/db not found

In this lab you are supposed to use /var/mongodb/db and not /data/db

~ Shubham

i tried to make it but still showing this error
db.createUser({ user: “m103-application-user”, pwd: “m103-application-pass”, roles: [{role: “readWrite”, db: “applicationData”}]}),

syntax error near unexpected token `{’

you have to do that after connecting to your mongod with mongo

same error repeating actually

almost there please help me out it breaking my head

solved ! answers are in the lessons bit tricky need to pay more Attention. thank you @Shubham_Ranjan @steevej-1495

Hi @B.Doondishwar_Kumar,

Thanks for the feedback. What part did you find tricky / confusing ?

~ Shubham

Im also having trouble with this question nothing I’m trying is helping I need a hand to get unstuck

post a screenshot of the issue in a new thread.

Mine is logging an error to the console:

ERROR: child process failed, exited with error number 48

I’m so lost

As already mentioned:

I don’t see how a screenshot would help :unamused:

I don’t see how I can help without a screen shot of what you are doing that shows the issue you are having.

Means another instance already running on same port/dbpath or address in use

Okay so what’s the solution?

There you go Sir.

Please run it without fork option.It will give more details on why it is failing
If another instance is already running kill it

Or it was already started for you.Please check your lab steps
Just connect to the instance and create the user

Without fork option