Course out of date: install instructions MongoDB 4.0.8

In the course video Chapter 2 / Installing the mongo Shell (windows):
the install instructions for Enterprise Server are for version 3.4.6 while currently it’s at 4.0.8.

So the instructions are no longer complete, as there is now an extra step in the installation, that asks:

  • Run service as a Network Service user
  • Run service as a local or domain user
    and then asks for some input about Service Name, Data Directory, Log Directory, and in case of second option account Domain, account Name and account password

Which option should I choose? And with what settings?

And please update the course video or at least provide a link with the most current information underneath it.

1 Like

In the course description you will find this information under System Requirements:

> * MongoDB: 3.6.2+ Enterprise

I think this is the version which will be used in all lessons and exercises. This is what you will get in this course.
The best fit will be version 3.6.12 in my opinion.

Thank you for your reply, but doesn’t + usually mean any version after said version?

I would expect the maker of the product to have their own ‘university’ up-to-date.

Given this, the slow or non-responses from teaching assistants, the install issues with Compass in chapter one and the fact that I could break the program quite easily doing normal things, I’ll just give up on MongoDB and have unregistered for this course.

I had the same problem, but then - following chrio suggestion - I just installed previous version 3.6.12 and it worked

I don’t doubt Chrio’s solution works, but I’ve wasted about 4 hours on chapter one, because Schema kept crashing, so I thought I’d spare myself the hassle of wasting even more.

So which is it? Run service as Network Service or Run service as a local or domain user?

1 Like

The current version (18.02.20) is 4.2.3, but it turned up not to be working ether (The setup looks a bit different with a Server / local options, but neither of them work).
I installed version 3.6.17 (Win 10, 64, msi) and it worked fine.

1 Like

Thanks Alexey, did you also go through the same command shell step?

Hi @Alexey_03616,

Can you please share the exact issue that you were facing while installing the MongoDB Enterprise Sever on your system?

Thanks,
Shubham Ranjan
Curriculum Services Engineer

Hi
Shubham,

Unfortunately, I don’t remember precisely and don’t have time to reinstall the server, so could be mistaken.

When I was trying to install the 4.2 I stuck on 3-4 screen when the “Server” / “Local” options were given. I tried both options, neither worked: there was some error (~server connection maybe, or even nothing happened). I remember that screen option was different from the course video, however, it is ok, just new.

I have Windows 10, 64bit. Perth, WA, Australia location. I am taking your 101 course.

Alexey.

1 Like

Hi @Alexey_03616,

Thanks for providing the information. I will have it tested on the Windows 10 system.

Please feel free to get back to us if you have any other query/concerns.

Happy Learning :slight_smile:

Thanks,
Shubham Ranjan
Curriculum Services Engineer