Couldn't install packages at requirements.txt

on executin pip install -r requirements.txt, it throws an error with the installation failed

Please share the full log so that we can take a look. :slight_smile: Make sure you are connected to Internet and firewall is disabled so that it can install dependencies and also activate the virtual env or anaconda before running the command.

Kanika

an error occured when i try to proceed the pip install -r requirements.txt

Okay, can you try running the app if it is able to start properly? Meanwhile I am looking into it.

Kanika

Hello I had the same error and I delete the requirement from the txt file and install that package apart. So far, the app is running

Hi @Paula_Carrillo

Thanks for flagging this, did you need to change the version of the package you installed for this or did the version listed in the requirements.txt file work when you installed it separately?

Thanks and kindest regards,
Eoin

I had problem with cffi and pyzmq packages. i installed pyzmq-22.0.3 and cffi-1.14.5, separately. So far everything´s worked fine.

Thanks @Paula_Carrillo, that’s really helpful to know!