Con't connect between replica

“Quorum check failed because not enough voting nodes responded; required 2 but only the following 1 voting nodes responded:; the following nodes did not respond affirmatively: failed with Connection refused”

this has been fixed. please ignore. thanks

1 Like

How do you fix that, I have the same problem.

Ok, I found the solution. You need to add replicas using the IP instead of the host name


Weeeelll :smiley: Funnily enough, that will be part of another exercise :wink:

I got this similar error from PRIMARY. After hours of experimentation - noticed I had in error ran ‘rs.initiate()’ on SECONDARY as well.

This figured out when I ran ‘mongo --port 27002’ it resulted into -
MongoDB Enterprise m103-repl:PRIMARY>

The solution is :a) Stop mongod and mongo session of port 27002
b) Modify the ‘mongod-repl-2.cfg’ by commenting out #replication entries
c) Delete /var/mongodb/db/3 folder
d) Start mongod and mongo session on port 27002
e) exit
f) recreate /var/mongodb/db/3 folder and then uncomment ‘replication’ entry.
g) connect to PRIMARY and attempt rs.add(“”) and tada… it worked!!!

Thanks for the tip !!