Connection issues in Sandbox

After working with MongoDB for some time in my programming course, I decided to go through the MongoDB University. But I can’t get along there at all. When I created my user, my password was autogenerated without me choosing this option and my computer crashed before I could copy it. If I specify the user again, Mongo only tells me that it has already been created. Is there a way to display the password? Secondly, I noticed that I can’t enter a password into the IDE. The console is not responding after the prompt. Can someone who has already gone through the webinar give me a hint? Thank you

I think you are referring to M001 course not M103
How was the user created?Must be from Atlas
Go to database access section
You will see the user you created.Change the password or delete user and create new user
In IDE just paste your connection string
When it prompts for password type your password and hit enter
You should be able to connect

Thank you for your answer Ramachandra, your solution for the issue with the password works. And yes I reffering to M001. But the console doesn’t let me type anything behind the prompt. It’s like readonly. I have changed the browser, but on Chrome it is the same. I tried it now with --password behind my username, but the test tells me it is incorrect.

Hi :wave: @Roman_Rostock,

We apologize for the inconvenience caused to you.

Can you help us to understand the issue better by letting us know certain information:

  • From which specific geographic location you are trying to access the MongoDB University? (Ex: Texas?)
  • Are you using VPN?

Also, please try some troubleshooting steps:

  • Command/Ctrl + Shift + R for the hard refresh of the page.
  • Logout and login again in to MongoDB University.
  • Clearing all the cache & cookies and launching the IDE again.

Best,
Kushagra

1 Like

Thank you Kushagra, clearing the cache has solved my issue.
Best Roman

2 Likes

Okay, all beginnings are difficult. I am now one chapter further. And we now use an srv-string, which I know from my programming course, where we connected directly from the application. I just copied the path out of the chapter and pasted my data.
I write: mongo “mongodb+srv://m001-student:m001-basic@m001.mongodb.net/admin” but I get DNSHostNotFound. I read the questions on this topic, but found nothing to help me. The mongo-server is running. And I tried the things from stack overflow. As region I use AWS N.virgina. I cleared the cache again. The path that worked this morning is also not accepted.

Have you created your Sandbox cluster and loaded sample data?
This(m001.mongodb.net) cannot be the Sandbox address
After creating your Sandbox cluster you can get your connect string from Atlas

Yes I have created an organization MDBU and the project M001 and loaded the sample data. The sandbox is active. I go to connect and copy my connection string. That is this one:
mongosh “mongodb+srv://sandbox.bmzb9.mongodb.net/myFirstDatabase” --apiVersion 1 --username m001-student
I write mongo and then passing in this connection string. I change myFirstDatabase into m001 and “apiVersion 1”. I press enter and the console ask for my password. I type in m001-basic. I don’t see that in the console. Thats what I have written in the first post. And I get this error back: "connection refused : connect@src/mongo/shell/mongo.js 374:17@(connect):2:6. The same I get, when I write instead behind the string --password m001-basic. I opened my prompt and runned netstat -an | find “27017” and it gives me back: TCP 127.0.0.1:27017 0.0.0.0:0 HEAR. So it finds the port. That is why I tried this other connection string, like I told you in the last answer. I deleted the user and added the same user again, but get the same result. I cleaned the cache , nothing happens. So I don’t know what is written in line 374 of this mongo.js. Thanks for your engagement.

I can connect to your cluster with old mongo shell without any issues using below command

C:\Users>mongo “mongodb+srv://sandbox.bmzb9.mongodb.net/myFirstDatabase” --username m001-student --password m001-basic
MongoDB Enterprise atlas-rzngwp-shard-0:PRIMARY>
MongoDB Enterprise atlas-rzngwp-shard-0:PRIMARY> db
myFirstDatabase
MongoDB Enterprise atlas-rzngwp-shard-0:PRIMARY> show dbs
admin 0.000GB
local 5.139GB

May be some software on your PC not allowing you to connect from IDE
Yes when you type password it will not show for security reasons

Do you have shell installed on your system?If yes you can try to connect from it

It works. Thank you.
Best Roman