Connection from Compass

I can connect using the IDE from the course but using Compass I get this error
querySrv ENOTFOUND _mongodb._tcp.sandbox.x6u09

What does it suggest is wrong ?
Connection is under general -
using same user, cluster info and following same pattern
mongodb+srv://username:password@sandbox.x6u09/mongodb.net/admin
The IP list includes any IP for any IP

It looks like you tried to type in your cluster address by hand rather than cut-n-paste it from the cluster UI.

You mistyped the / between x6u09 and mongodb.net. You need a dot not a slash.

1 Like

Thanks - for catching that error. I replaced the / with . but still get an error with a meaning that’s unknown.
Here is the connect string with password as placeholder: mongodb+srv://user1:password@sandbox.x6u09.mongodb.net/admin
error : etaddrinfo ENOTFOUND sandbox-shard-00-02.x6u09.mongodb.net

also I dont see a cluster view on my Compass - but when I log on web I get this Copy the connection string, then open MongoDB Compass.

mongodb+srv://<username>:<password>@sandbox.x6u09.mongodb.net/test

mongodb+srv://username:password@sandbox.x6u09.mongodb.net/test
works on 1 device - but not on another …
The one that does NOT connect is on a VPN - I picked up today IP and added it along with the anything goes IP but still get same error

Hi @Andrew_Watts,

This seems to be a local DNS error:

I hope it helps!

Thanks,
Kushagra

2 Likes