Connection Failed MongoDB version is 3.6.21-11.0 but version >= 4.0 required

I am trying to connect my MongoDB version 3.6.21-11.0 with the BI connector 2.14.5 + MongoDB ODBC Driver 1.4.3 and 1.4.2 but I get the following message:

Test Result

Connection Failed
[MongoDB] [ODBC 1.4(w) Driver]MongoDB version is 3.6.21-11.0 but version >= 4.0 required

The same process on the same database has been run from another person at May (5 months prior to my test) with BI connector 2.14.4 + ODBC 1.4.2 and everything run smoothly.

Welcome to the MongoDB Community @Lampros_Makrodimitris !

MongoDB 3.6 reached End of Life (EOL) in April 2021 and is no longer supported. The error message indicates your installed connector version expects a MongoDB 4.0 or newer deployment.

Per the Release Notes for MongoDB Connector for BI, version 2.14.4 of the connector removed support for MongoDB 3.2, 3.4, and 3.6.

You can either upgrade to a newer version of MongoDB server (I recommend at least 4.2 since 4.0 is also EOL) or download an older version of the BI Connector (2.14.3).

Regards,
Stennie

1 Like

@Stennie thank you for the solution.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.