Connection command from Chapter 0 not working

It’s giving me this error, what am I doing wrong here?
I’m on Windows 7 PC


Unfortunately your screen shot is very small and impossible (for me anyway) to read. I assume you’re running this from the Windows command line, correct? Please copy the text as text and post back here and I’ll try to help. Good luck.

Ok, I copied the output from the Command line, and it’s this:

D:\Programas\MongoDB Server 4.0\bin>mongo.exe
MongoDB shell version v4.0.6
connecting to: mongodb://
Implicit session: session { "id" : UUID("bf1515af-1948-4a24-89c5-a98b162bb9fe")
MongoDB server version: 4.0.6
Server has startup warnings:
2019-03-16T19:40:26.088-0300 I CONTROL  [initandlisten]
2019-03-16T19:40:26.088-0300 I CONTROL  [initandlisten] ** WARNING: Access contr
ol is not enabled for the database.
2019-03-16T19:40:26.089-0300 I CONTROL  [initandlisten] **          Read and wri
te access to data and configuration is unrestricted.
2019-03-16T19:40:26.089-0300 I CONTROL  [initandlisten]
2019-03-16T19:40:26.089-0300 I CONTROL  [initandlisten] Hotfix KB2731284 or late
r update is not installed, will zero-out data files.
2019-03-16T19:40:26.089-0300 I CONTROL  [initandlisten]
MongoDB Enterprise > mongo "mongodb://
17,,cluster0-shard-00-02-jxeqq.mongo" --authenticationDatabase
admin --ssl -u m121 -p aggregations --norc
2019-03-16T23:08:49.618-0300 E QUERY    [js] SyntaxError: missing ; before state
ment @(shell):1:6
MongoDB Enterprise >


OK, you need to run your ‘mongo’ command from the Windows command line, not from within the shell. It’s not a shell command. Note the documentation here that shows you a variety of options, all run from the command line.

It worked!! Thanks DHz!
I actually tried doing it directly from the Command line first (Yesterday), but it didn’t recognize mongo as a command… I don’t know what changed exactly, but now it’s working!
Thanks for the support!