Connecting to your sandbox cluster to Compass

I followed the video by clicking on my sandbox name which is

then I clicked on my primary
at first there was a string ending in .net just like the video but now no matter how many times I log out & re-login to capture that original string it is giving a string that ends in fsgm
in case the below screenshot does not come through, this is the string:

When I copy the string into Compass I get an error message:
MongoDB not running on the provided host and port.

Please help, thank you!


Please check this link.It may help you

Not able to Sandbox Cluster from Compass

The string you pasted is not complete
If you cannot get the full string try creating another sandbox cluster under different project name

So I tried to create another sandbox by doing a new account in atlas under my maiden name Arlene Sadler because I had an earlier problem to correct getting an Enterprise account & not being able to change it to free.

Now I am going through all the videos again and I have this error in the shell:

imac:~ McMillan$ mongo mongodb+srv:// --username m001-student --password m001-mongodb-basics

DNSHostNotFound: Failed to look up service “”: Undefined error: 0

try ‘mongo --help’ for more information

How do I correct this error?

I tried connecting the sandbox and compass and the error message is:

bad auth Authentication failed

Any help is greatly appreciated!

I got the same error message. It turned out I had mis-typed my password. Since the password is not displayed when you are typing it in, sometimes it’s better to type it out on a text editor and then just copy and paste it into that field.

Hi @Della_90614,

This error mostly occurs if either you are using incorrect username or password while connecting to the cluster. Try typing your username and password instead of doing copy/paste.

Also, check that your connection parameters are correct.


Hi @Della_90614,

This error usually occurs if your connection string is not correct. Please check your connection string from Compass and copy/paste the same in your terminal.

If you still see the same error, please share the screenshot of the Connection String from Compass.

Also, try to run the following command in the terminal:


If you are not able to ping using the above command, then disable any firewall or antivirus.

Please let me know, if you have any questions.


1 Like

Hi Sonali,

Now I am confused on where to start. If I do not get this resolved in time how do I discontinue this class and then sign up for the next beginners course?

I have attached screenshots of my shell, compass and cluster.

Please advise, thanks,



May be issue with your user id/password as it says bad authentication
Make sure no spaces or invalid characters while cut & paste or try to type

Your ping result is different from the hostname you are using in the string
You can discontinue the course by using unregister at bottom on course page

Hi @Della_90614,

As mentioned by @Ramachandra_37567, “bad authentication” is generally due to wrong username/password.

However, the next course for M001: MongoDB Basics starts from 16 July, 2019 17:00 UTC. Please register for it and if you have any doubts/questions, please let me know.