Connecting to virtual box in windows

I followed the instructions and it appears that Virtual box and Vagrant are both installed but the subsequent instructions to connect to the VM are for Linux environment only. Where can I find instructions for win 10?

same here
i tried running vagrant up on cmd windows, got this errorm

1 Like

The vagrant commands are not Linux-only, what led you to that conclusion? If the commands cannot be found, it could be a config issue in Windows, like the search path.

In this case, you are also being warned that Powershell itself isn’t installed. So please make sure you install the most recent Powershell.

1 Like

This is what I am getting

Hi Ashok_81119,

You need to download the handout for vagrant environment, then use command vagrant up from that directory.

Please take a look at this post: Installing, Setting up Vagrant and Run Validation Scripts


1 Like

Like Kanika said: if you don’t download and setup the class handouts, there’s nothing for Vagrant to work with :slight_smile:

This is not a matter of Windows vs Linux.

I think the installation was done without any issues. I thought running the vagrant up from anywhere would be fine since I had that in the path, but it seems that it looks for the other files like.ini etc. so as per your reminder I ran the command from the directory it self. This did get me a little further and now getting the following error:

Inline image



Found the problem.vagrant. Had to enable hyper v in BIOS
Hope this helps some one.

No, you did not enable Hyper-V in BIOS, you enabled VT-X :slight_smile:

Hyper-V is a Windows feature for native virtualization in Windows :slight_smile:

I’m glad you got it working though!

Actually I did have to go in Bios with F12 at the boot time then enable the Hyper-V. It may mean VT-X in our context so thank you for pointing this out.

hey guys, when i run vagrant up, it works up on till it wrote ssh command responded with a non zero exit.s
but when i run vagrant ssh, everything seems fine. but when i type mongod --version it tells me mongod is not installedc

1 Like

can you try the halt and then start with up and --provision again and then try ssh? Make sure to be in the folder where you have the class files downloaded and unzipped.

  1. vagrant halt
  2. vagrant up --provision
    now try
  3. vagrant ssh

i tried it…nt1
then i opened the virtual box as advised and ran vagrant ssh and got back to the same ssh command zero exit


Someone else can shed more light. I did come accross the same issue, but as per Kanika’s suggestion, I found out that my issue was that I wasn’t running from the right directory/folder.

Also before you run vagrant ssh, you have to make sure that the vagrant up --provision ran successfully.
You can check that by running vagrant status.

1 Like

@Ashok_81119 it shows virtualbox is runnungnt3
but when i run vagrant ssh and run mongog or even vagrant it tells me its not installednt4

Could you please retry the provisioning command?