Connecting to sandbox cluster

having successfully connected to the sandbox cluster i created both from compass and the shell yesterday cannot connect today. When I try to get connection from compass receive message ‘bad auth Authentication failed’. I have checked the video to see fields are filled in correctly and password is correct. have also done connection problem checks suggested here

Hi PIERS_81809,

If you are connecting to your sandbox cluster, then please re-check with the users through cloud.

  • Go to Security -> Users

  • Or you can just click on Command Line Tools , and check if you can connect through your terminal window.
    Connect -> Connect via Mongo Shell

  • Is your IP Whitelisted. Go to Security -> IP Whitelist tab -> Allow Access from Anywhere

Let me know.

Also, can you share the command you are using, incase you are still not able to connect.
Or on a safe side, create one more user with simple username and password and try again.


Thank you for your response.

As per the video instructions I copied the standard connection string from -> connect via the mongo shell to the command line and replaced the password as instructed. This worked the first day and i was able to connect but now it says ‘exception: login failed’ which is caused by bad auth Authentication failed, The same error occurs if i try to connect to the sandbox from compass. I have followed all the video instructions for example have allowed access from anywhere and am able ping,

would deleting the cluster and starting again be an option?

thanks again

maybe the password for the mongoDB user is different?

you could try deleting the m001-student and creating a new user

1 Like

Kanika Singla

I cannot connect to my cluster, I am getting

What does that mean? Is there a way of checking/ or resetting the details for my cluster in Atlas?

Please check for Replica set name.

You can use and click on Connect -> Connect through Compass.

Let me know if it helps.


Thanks for getting back to me, I had to re-install Compass twice before it finally worked with all the same credentials so it’s a problem with how it downloads I guess.

1 Like

I am in the the middle of chapter 3 and this message comes up.

What does that mean? What is the problem?

Generally, this message appears when you submit all the answers of Final Exam.

From your screenshot, I see only message. Please share the full screenshot so that I can understand better.


Thanks for getting back to me, that’s what I presumed but I have only answered two questions on the exam and not even completely finished the lectures in Chapter 3 so you can understand my confusion.

Hi Zack_67637,

Thanks for sharing the information. I have notified the team, we will soon do the changes.

For now, please ignore the message and Good Luck with the course!