Connecting to Our Class Atlas Cluster from Mongo Shell

Hi, CMD shell is throwing me this error “Syntax Error : missing ; before statement” on providing this statement to connect to Altas Cluster - mongo “mongodb://,,” --authenticationDatabase admin --ssl --username m001-student --password m001-mongodb-basics

Kindly let me know how to proceed.

I am getting this error - Failed to adjust token privilege for privilege ‘SeIncreaseWorkingSetPrivilege’

I am able to connect to my Sandbox cluster

how did you fix it? I am receiving the same error.

Please share the command so that I can help better. And if you are in a mongo shell, please exit the mongo shell and then try connecting. Here is the command for reference.

mongo “mongodb://,,” --authenticationDatabase admin --ssl --username m001-student --password m001-mongodb-basics


How do I exit and restart it?

If you are in Mongo shell, you need to press [control + C] to exit the mongo shell:

 MongoDB Enterprise > 

Or you can just open a new terminal tab and connect using the command I shared.


I tried both of those methods and still received the same error.

Please share the screenshot and command you are using to connect.



I am getting the below error even after using the same command given this discussion forum.
mongo “mongodb://,,” --authenticationDatabase admin --ssl --username m001-student --password m001-mongodb-basics
Please find the screenshot attached for your reference.mongoDB_Cluster_error

@Kishor_KP_25724, When you copy paste, Please replace the double quotes. It’s replacing with some other special character. It’s worked for me




You need to replace both the places.

mongo "mongodb://,," --authenticationDatabase admin --ssl --username m001-student --password m001-mongodb-basics

@Kanika, Please use “Reformatted text” behalf of “Blockquote”, so it will work when we copy paste.


Hi Kishor_KP_25724,

You don’t need to run mongo --nodb before connecting to our Atlas cluster. The command mongo --nodb will connect with the Mongo Shell without any database connection.

The connection string which I shared will let you connect to Mongo:

C:\Users\PattabKi> mongo "mongodb://,," --authenticationDatabase admin --ssl --username m001-student --password m001-mongodb-basics


In instructor’s lecture, showed in Altas , we can find one line like you have "mongo “mongodb://,,” --authenticationDatabase admin --ssl --username m001-student --password m001-mongodb-basics. *** this line is for each student created sanbox cluster , we can run in window mongo shell to connect to sanbox in Altas. My question is: How I open Mongodb Altas. a URL ???

To begin creating your Atlas Sandbox cluster, visit and complete the account creation form you see on that page

Hello, I am trying to connect to the atlas cluster but I`ve got the following command to connect it:

Please your help.

Hi @Christian_Cuenca_46307,

I am able to connect to the sandbox cluster using the following connection string:

mongo “mongodb+srv://” --username m001-student --password m001-mongodb-basics

Please make sure that you are not getting blocked by any firewall or antivirus and you are not trying to connect to the cluster in the office network.

Please try the above connection string without the inverted commas (" ").

Let me know, if it still doesn’t work.


thks a lot, it works.