Connect using compass

Hello guys, sorry if this question is a little annoying, i have been trying to connect to the aggregations database using compass but i have been unable to do so.

Given the connection string provided in chapter 0:

mongo “mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/aggregations?replicaSet=Cluster0-shard-0” --authenticationDatabase admin --ssl -u m121 -p aggregations --norc

I copied the string inside the double quotations but that does not work, also tried setting each field manually but the same error shows.

Can i have some help please on how to connect to it using compass?

Hi @Carlos_Bravo,

Are you using the latest version of MongoDB Compass which is currently 1.30.1?

Are you able to connect with the Mongo Shell?

Cheers,
Maxime.

@Carlos_Bravo make sure that System CA / Atlas Deployment is selected for SSL and the Replica Set Name is set in the More Options tab:

Thank you! The SSL configuration is what I was missing.

1 Like

The error I get is: Authentication failed

I put the user and password: u m121 -p aggregations, everything else is the same as in the images of Carlos_Bravo and Massimiliano_Marcon

I have reinstalled Compass and now the connection is working

2 Likes

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.