Compass error: 'not master and slaveOk=false'

I used Compass in the first week of the class, now I am mostly using the Mongo Shell. For the final exam the first 2 questions require looking at the Schema. So I fired up Compass and could not get back into the class Atlas cluster from my favorite which used to work.

Got the error above. Following instructions, I changed to Primary Preferred, then Secondary Preferred, then Nearest. Still doesn’t work. Double checked everything in connection dialog (which I pasted in from lecture notes). Quit compass tried again. Still can’t connect. This used to work and I can connect fine with Mongo Shell so I am stumped. I could live with doing everything in the shell if the final didn’t have the schema questions.

Any ideas?
P.S. I noticed the Disconnect menu item on Mac is always there. Assume that this is the case and I am not failing to Disconnect but that is the only strange thing I see.

Hi Joseph,

Can you try reconnecting to the cluster now? We were having issues with connection yesterday.

If it doesn’t help, check if you have latest version of Compass, its 1.15.4 Stable version, if you have any version less than that, please install the latest version and check again.

Also, you can try pasting me the connection page values, that would be more helpful for me to identify the exact problem.

Here is the link, that contains the connection settings for Compass.

Let me know if doesn’t work!


I have the same error message. I’ve just installed Compass on Ubuntu 18.04 x64 and get following message after clicking ‘connect’ button :

“An error occurred while loading navigation: ‘not master and slaveOk=false’: It is recommended to change your read preference in the connection dialog to Primary Preferred or Secondary Preferred or provide a replica set name for a full topology connection.”

1 Like

Hi Brent_07328,

Please check the following:

Compass Connection: [Solution]An error occurred while loading navigation: ‘not master and slaveOk=false’

Please ensure the following:

  1. Make sure it is MongoDB Compass Stable version i.e 1.16.1
  2. Ensure that you have written all the parameter names correctly. No whitespace should be trailing in the cluster name.
  3. Try to switch off SRV Record (incase it was switched on)
    If the above points don’t resolve your issue, then quit Compass, klll The MongoDB GUI process and start Compass. Ensure all the above points are met and connect.

If the above step still does not solve your problem, then please follow the above point of quitting Compass, killing the process and re-install Compass.

Thanks, Kanika

Hi Kanika

I’ve tried all the options you suggest on a new copy installed under Windows 10 x64, but experience the exact same error.

Is there no other way I can attempt this course without using Compass?

Kind regards,


Hi Brent_07328,

You can install Compass and on your local mongo, import data of our Cluster from here.

Then you can connect to your own Mongo cluster through Compass and go through all the labs.

Let me know if you need help!