Child process failed, exited with error number 1.0, again

Very frustrating. I followed all the lecture instructions to set up the replication.
I created all the folders, files, config files etc. When I started up got this error.

Ok. You just need to run the file without the option “–fork” let’s go back to vi (and I really don’t like to use it), get rid of the --fork option, start up the file and nothing happens. No mongod server, no error, nothing happens.

Then I read all forum topics. I went back to all files and folder structures on this exercise and gave them permission to do ALL. 777.

As I started up the mongod.conf, same error number 1 again. Disable --fork, start the file again. Nothing happens. The mongod.conf file, from the previous lesson is working fine.

I need to understand why. I’m trying for 3 hours to start up one simple set. And I keep imagining how fun I’ll get if I need to install those 50 sets. :joy:

Please check your config files again
Most likely some dir missing or not matching with what specified in your cfg file
Did it create any logfile?Check the logfiles
When you said after removing --fork it did not give anything.
Did you check if mongod’s are up from another session or tried to connect
ps -ef|grep mongod

Hi @Diggerfdf,

I hope the post by @Ramachandra_37567 helped you.
If you are still facing any issues, please let me know.