Chapter 5: Indexing and Aggregation Pipeline Lab: Aggregation Framework IDE Array Problem

I gave the correct answer, but it doesn’t work on the IDE. I can’t use mongosh right now. my score wasted

Missing one quiz or lab is not such a big deal for your final pass or no-pass certificate.

What is a big deal is that you

Post a screenshot of what you are doing that shows the issue you are having while trying to use mongosh. Have you tried with the old mongo command line?

1 Like

Is there a way to show arrays on the IDE? Connection fails on Mongosh. I am typing my database name and username. I’m deleting the APIversion line. Still not working. How are you logging in?

Cannot see what you are doing wrong if you do not

Like it is shown in Chapter 0.

This is how I call it. If you want, you can connect and try


The problem is that you type mongosh and press ENTER and then you type mongosh again.

The string you copied that starts with mongosh is the whole command line. The URI is the string between the double quotes.

I already tried it as mongosh. That’s how I log in with the IDE. Likewise it doesn’t log in here

The mongosh command should work in the IDE.

Common-10001 invalid uri

Same issue as How to use Mongosh to connect the course's cluster? - #12 by steevej

The trick for me is: omit --apiVersion 1 !!

So use this command directly when you open the IDE:

mongosh mongodb+srv://mfix.lpapc8i.mongodb.net/Mfix --username m220student

Using this I get an "Enter password:" prompt so it should work for you as well. :slight_smile:

1 Like

I’m not logged in either, I guess I should check other things.
Thank you for your help