Chapter 4: Tying It All Together Learning Activity: Big Bank Database Internal Authentication

I get this error when trying to start mongod. Not sure what I am doing wrong

You might have moved to a different directory
Check if config file exists

ls -lrt mongod_1.conf

Thanks for the guidance Tummala. Not sure what I did differrent because I had started all three file before but had some errors and reset my workspace then this.

Can I have this portion of the exercise reset so I can complete m150?

I created dbpath /var/mongodb/1/db and I’m back on track. Thanks again Tummala for your assist.

1 Like

I guess this was just making me feel good. Back to same error as screen shot above with no such file or directory error. Even after making the supposed missing dir. Help

Show output of pwd and ls -lrt
Did you try reset workspace?

@Ramachandra_Tummala I did reset the workspace. Here is the screenshot of the above commands

I reset workspace again, added keyFile on all 3 nodes, started mongod, connected to one of the nodes, infact I ran all the steps but in the end I got this other error when I clicked on “run test”


The keyfile exist on all three conf. files.

I was able to fix error. I used grep to see running processes. killed process running on the 3 mongod files, reset workstation and started by checking every step to make sure no spaces were present. I found out there was an empty line right below my keyfile on node 2 and node 3. deleted and everything worked like a champ. Thanks @Ramachandra_Tummala for the assist.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.