Chapter 1: Introduction Lab 1.1: Install Course Tools and Datasets

I am unable to complete the Install Course Tools and Datasets in lab 1.1 I am getting an error in my shell. I connect to the sandbox cluster in my mongo DB compass and I am attempting to download the data set in my shell but it is not working. Please help I have been stuck on this for a while

Have you installed mongod tools?
If yes it could be path issue
Update your tools/bin to your path
or
You can cd to your bin dir where mongimport executable is residing and run the mongoimport command


its still not working, i downloaded mongod tools and placed the folder in a m201 folder i created

i imported correctly but i am unable to use the m201 database

You connect to your cluster then switch to m201 DB
You are running the command at your os prompt which is not correct


ok i ran the command after connecting to the database but getting the error attached

You imported data to your local mongod.
You should connect to your local instance but looks like you connected to class cluster
Please check and try again

How do i connect to the local instance? i am only familiar with the class cluster

Please check your mongoimport command
Connect string to connect to your local instance is there in it
or
Just issue mongo


is that what you mean?

i figured out what i was doing wrong…really appreciate the assistance


how do i connect to the database via the shell…i am not sure why the mongodb+srv is not working

It is not mongoosh
Try with mongosh

Thank you very much…it worked and again I appreciate the assistance

1 Like