Chapter 1: Driver Setup - Error running pip install -r requirements.txt and python on Windows

Hello all,

I have followed all steps from Chapter 1 (Lecture: README: Setting Up mflix) and I am having these problems righ at the end:

  1. When I run pip install -r requirements.txt, I get the following error among other success messages:
    (mflix) C:\Users\Javier\M220P\mflix-python>pip install -r requirements.txt

    ERROR: spyder 4.0.1 requires pyqtwebengine<5.13; python_version >= “3”, which is
    not installed.
    ERROR: pytest-astropy 0.8.0 requires pytest-cov>=2.0, which is not installed.
    ERROR: pytest-astropy 0.8.0 requires pytest-filter-subpackage>=0.1, which is not
    ERROR: spyder 4.0.1 has requirement jedi==0.14.1, but you’ll have jedi 0.15.1 wh
    ich is incompatible.
    ERROR: spyder 4.0.1 has requirement qtconsole>=4.6.0, but you’ll have qtconsole
    4.5.5 which is incompatible.
    ERROR: pytest-astropy 0.8.0 has requirement pytest>=4.6, but you’ll have pytest
    3.3.0 which is incompatible.
    Installing collected packages: terminado, notebook, ptyprocess, pexpect, pluggy,
    py, pymongo, pytest, pytest-flask, qtconsole
    Attempting uninstall: terminado
    Found existing installation: terminado 0.8.3
    ERROR: Cannot uninstall ‘terminado’. It is a distutils installed project and thu
    s we cannot accurately determine which files belong to it which would lead to on
    ly a partial uninstall.

  2. After this, when I run python I get the following error:
    (mflix) C:\Users\Javier\M220P\mflix-python>python
    Traceback (most recent call last):
    File “”, line 1, in
    from mflix.factory import create_app
    File “C:\Users\Javier\M220P\mflix-python\mflix\”, line 9, in
    from bson import json_util, ObjectId
    ModuleNotFoundError: No module named ‘bson’

Just for your info, I set the ini file like this and think is correct:
SECRET_KEY = m220p-mongodb-python
MFLIX_DB_URI = mongodb+srv://
MFLIX_NS = sample_mflix

SECRET_KEY = m220p-mongodb-python
MFLIX_DB_URI = mongodb+srv://
MFLIX_NS = sample_mflix

I’m pretty new to all this configuration stuff and I’m really stuck here, any help would be much appreciated, otherwise I cannot continue with the course.

Thank you very much!

Hi @jrazpeitia,

Let me know if the issue is resolved.


Maam even I was stuck i here…
so i decided to run it manually…
open the requirements.txt folder and start to pip install all the modules manually…
TIP: Start installation from below as many modules in the below will already the resolve the needs and the requirements will start to appear “Already Satisfied”…

If you could move over this plaese help me in the pytest -m connection…
This does not work for me.I get the follwoing error:

Please do not ask the same question in multiple thread.

It slows people trying to help by having them read duplicate posts.

1 Like

Same problem installing requirements. Error on “cffi-1.13.1”.

When i try install manually witch pip, then show that requirement already satisfied (version 1.14.5).

P.S. previous training M220p with python+bottle was better

Ok, installed all requirement manually, but now ‘flask-jwt-extended’ dont have ‘get_jwt_claims’. Total version mess.