Chapter 1: Driver Setup - 404 page not found while accessing http://localhost:5000/status

I’m getting 404 while accessing to http://localhost:5000/status. Trial to access http://localhost:5000 ends with blank page (server returns 200, but page is empty). App starts correctly, I see no exceptions (even in debug mode). Package with project comes from chapter 0 handouts. Anyone? :frowning:

Can you the last 20 or 30 lines of output you get when you do mvn spring-boot:run.

I see nothing wrong. I would give another go at it.

Unfortunately, even after I downloaded files once more, it still doesn’t work. :frowning: I’m running it on Java8. Maybe there is another way to download source files for project? Eg. sources on github?

If Linux, please provide the output of netstat -tlnp.

If not Linux, I don’t know. Well I know, but I am not setup to test what I propose so I will let others help you.

I am geting 404 as well.

The console throws me an error ,Unauthorized error: Full authentication is required to access this resource

I committed this error. You need go to this page using button in root web page.
The error is simple. You try to access to a spring boot Web page without neccesary beans.

Load localhost:5000
Click button status


I did that and now I can see status page, however I’m getting this error on console:

2019-02-18 19:00:24.420 ERROR 1091 — [nio-5000-exec-3] : Unauthorized error: Bad credentials
2019-02-18 19:00:24.462 ERROR 1091 — [io-5000-exec-10] o.a.c.c.C.[.[.[/].[dispatcherServlet] : Servlet.service() for servlet [dispatcherServlet] in context with path threw exception [Filter execution threw an exception] with root cause

java.lang.ClassNotFoundException: javax.xml.bind.DatatypeConverter
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass( ~[na:na]
at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass( ~[na:na]
at java.base/java.lang.ClassLoader.loadClass( ~[na:na]
at io.jsonwebtoken.impl.Base64Codec.decode( ~[jjwt-0.9.1.jar:0.9.1]
at io.jsonwebtoken.impl.DefaultJwtParser.setSigningKey( ~[jjwt-0.9.1.jar:0.9.1]

Hi Even I’m getting this error while clicking on status page.

Whitelabel Error Page

This application has no explicit mapping for /error, so you are seeing this as a fallback.

Tue Apr 16 14:21:39 IST 2019

There was an unexpected error (type=Unauthorized, status=401).

Not authorized to access this resource.

please help me out

issue solved thank you

Thankyou so much Sir !!! You Rock

Thanks @albertoggago. I got it resolved because of your post. I think course content should be changed to reflect this.

My Bad I also made the same mistake. T
Thanks this was helpful