Can't pass last assignment in Chapter 1 - Issue?

I am talking about the assignment: “Use the shell space below to connect to your Atlas cluster.”

I am managing to connect successfully, however I am failing the assignment with the message:

[FAIL] “The cluster name is Sandbox” Did you name your Atlas cluster Sandbox?

However, this is not the case, my cluster is named Sandbox.

Does anyone else have this issue?

Post a screenshot of the whole IDE so that we see how you connect.

Sure :slight_smile:

Please see the attached screenshots.


May be the validation script is picky and assume that Sandbox is not the same as sandbox.

Try putting an upper case S in your connection string.

Also post screenshot of the Atlas screen for the status of your cluster.

Thanks for the help!
Yes pretty weird…

I tried with a capital S and it is not working either.
Here is a screenshot of the status of my cluster.

I have flagged your post so that they look at it quickly.

1 Like

Thank you so much!

I have the same issue:

  • on Atlas, my cluster name is Sandbox
  • terminal displays:

3 total, 2 passed, 0 skipped:
[PASS] “Successfully connected to the Atlas Cluster”
[FAIL] “The cluster name is Sandbox”
Did you name your Atlas cluster Sandbox?
[PASS] “The username is m001-student”

It’s some sort of nonsense…

Did you try with other form of string?
Does it fail with it too?

mongo “mongodb+srv://” --username m001-student

I have successfully connected with

mongo “mongodb+srv://”

mongo works fine, only these test fail for no reason :frowning:

Yes, it fails too.

I did some testing and think I figured out the problem. I am pretty sure it is a bug.

When creating the Project M001 the first cluster you create inside has to be the cluster named Sandbox.

If you create the Project and then create any other cluster inside the test fails. Even if you delete the cluster again and only have the Sandbox cluster present.

I have tested this and I am able to recreate the issue.

1 Like

I have tried @Ramachandra_37567 idea of using the –username option rather than putting the username and password in the connection string and it works.

So rather than

mongo "mongodb+srv://"


mongo "mongodb+srv://" --username m001-student --password m001-mongodb-basics

to connect before Run Test.


Yep, it worked!

I get this error while running above command. Please advise

bash-4.4# mongo “mongodb+srv://” --username m001-student --password m001-mongodb-basics
DNSProtocolError: No SRV records for “”
try ‘mongo --help’ for more information

You have to use the URI of your own cluster. The cluster name is an example.

Thanks @Lisa_N_A ! this is an interesting find. I’ve created a ticket to address it. Thanks for reporting and investigating on this. :slight_smile:

I have the same exact issue, Do we have a solution for this?

The solution is this thread, a few post above.

I am trying to connect using in browser IDE and unable to do so since Wed.

mongo “mongodb+srv://” --username m001-student --password m001-mongodb-basics

tried following also.

mongo “mongodb+srv://”

Please let us know if it’s bug or correct command to connect?