Cant load ''loadMovieDetailsDataset.js''


They don’t appear to be double quotes
Please check

As @Ramachandra_37567 said,

Don’t use ’ character twice.
Instead, you should use double quotes " character. You can type it by pressing (Shift + ’ )

You can copy and paste this:

Hope it helps.


It should be double quotation marks(") around loadMovieDetailsDataset.js, not the single quotation mark twice (’ '). :smile:

Happy Coding!

Cant load ”loadMovieDetailsDataset.js”
Any helps ?Please.

Hi @victor_28996,

Please navigate into M001 folder in your system and then reconnect to the Sandbox Cluster and you will be able to load the loadMovieDetailsDataset.js script successfully.

For better understanding you can also refer to Lecture: Loading Data into Your Sandbox Cluster in Chapter 2.

If you are still facing any problem, please let me know.


1 Like

Hi Sonail,

Yes, still having the same issues.
I am following Lecture: Loading Data into Your Sandbox Cluster
I am doing exactly what the lecturer said over the video.

any helps?


Hi @victor_28996,

Can you please share the screenshot of the complete Connection String?


here it is


Hi @victor_28996,

You have saved loadMovieDetailsDataset.js in the loadMovieDetailsDataset folder.
Please navigate into loadMovieDetailsDataset folder from your current directory using following command:

C:\Users\victogo2> cd M001\loadMovieDetailsDataset

Then try reconnecting to the Atlas Cluster.


Yes, I have saved loadMovieDetailsDataset.js in the loadMovieDetailsDataset folder.

I did also C:\Users\victogo2> cd M001\loadMovieDetailsDataset

still not working.

I am curious about the message over over the sreenshoot saying " Error while trying to show server …

best regards,

Hi @victor_28996,

Please note you need to type just the following to navigate to loadMovieDetailsDataset directory:

cd M001\loadMovieDetailsDataset

If you are still facing the problem, please share the screenshot of output of the above command.

Moreover, the warning message “user is not allowed to do action [getLog] on [admin]” is because getLog action can be performed by the clusterMonitor. You can ignore this warning message for now. Please refer to the following doc for more details on this message:


Hi Sonali,

Sorry but still not working

I have highlighted when I am navegating in my directory and then when I tried to load the file.


Does the .js file exist in your dir?
Can you list files by dir
If its exists and still failing use this way


1 Like

Hi @victor_28996,

Please try this solution:

Let me know if this helps.


Hi Sonial,

I have check the directory. I can see the folder “loadMovieDetailsDataset” but I can not see the file ’ "loadMovieDetailsDataset.js”

I have tried : load(“C:/Users/your_username/M001/loadMovieDetailsDataset/loadMovieDetailsDataset.js”)
but still not working.

I am wondering problem with TLS/ SSL

I am wondering if I have problem with the verion of the shell installed and the version of shell of my connection string. I must copy 3.4 or earlier.


If file is not there your load command will not work
Why it is missing?
You would have got a zip file from your hanadouts
Just unzip it under M001
You should see something like this

Volume in drive C is OS
Volume Serial Number is FCFB-3D6A

Directory of C:\Users\ramrt\M001\loadMovieDetailsDataset

01/10/2019 01:56 PM .
01/10/2019 01:56 PM …
01/10/2019 01:56 PM 1,381,666 loadMovieDetailsDataset.js

I am facing the issue after going to the path cd m001/loadmoviedetailsdataset/ i am unable to connect to my sandbox cluster (using terminal - Mac). it giving me an error -bash: mongo: command not found.

Please share your thoughts

Have you updated your PATH variable to include mongodb.Seems to be path issue to me
Can you invoke mongo by giving full path of mongo executable

it was working fine from the root directory ( defined path earlier) but after navigating to .js file path try to connect to mongodb cluster it is giving the error-bash: mongo: command not found.