Can't launch in-browser Integrated Development Environment Lab

  • Issue:
    When ever i click in a button “Click here to launch your lab”, it’s open a new tab with literal “404 Not Found” content.
  • Link
  • Expect:
    in-browser Integrated Development Environment Lab to be open and launch
  • Environment:
    Chrome Beta 122 on MacOS 13.0.1
1 Like

the same for me
here is what i get

Unexpected Application Error!

error loading dynamically imported module: https://static.instruqt.com/6670-65b10081d-Production/public/PlayAppContainer-C_mVj4N8.js

Hey @AAMTAA_N_A ,

Can you tell me in which lab this happened?

Same Here, getting this – after clicking any “Click here to launch your lab” button in the Introduction to MongoDB course –

it sends me to the url:

https://ti.instruqt.com/?track=https://play.instruqt.com/embed/mongodb/tracks/managing-databases-collections-and-documents-in-atlas-data-explorer?token=em_wMAkdzlUFa6OrDom&jwt=eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJjb3Vyc2VUaXRsZSI6Ik1vbmdvREIgYW5kIHRoZSBEb2N1bWVudCBNb2RlbCIsImNvdXJzZVNrdSI6Ik1EQlVuaXQyRG9jIiwiY291cnNlSWQiOiJlMTdjNjYwNS0xZjQ0LTQ5YzYtODI2My1jNjIzNzkzYWNhOTkiLCJyZXR1cm5UbyI6Imh0dHBzOi8vbGVhcm4ubW9uZ29kYi5jb20vbGVhcm4vZXh0ZXJuYWxBY3Rpdml0eT9qd3Q9ZXlKaGJHY2lPaUpJVXpJMU5pSXNJblI1Y0NJNklrcFhWQ0o5LmV5SnpkR0YwZFhNaU9pSmpiMjF3YkdWMFpXUWlMQ0p5WlhSMWNtNVZjbXdpT2lJdmJHVmhjbTR2WTI5MWNuTmxMMjF2Ym1kdlpHSXRaRzlqZFcxbGJuUXRiVzlrWld3dmJHVnpjMjl1TFRNdGJXRnVZV2RwYm1jdFpHRjBZV0poYzJWekxXTnZiR3hsWTNScGIyNXpMV0Z1WkMxa2IyTjFiV1Z1ZEhNdGFXNHRZWFJzWVhNdFpHRjBZUzFsZUhCc2IzSmxjaTl3Y21GamRHbGpaVDlqYkdsbGJuUTlZM1Z6ZEc5dFpYSW1jR0ZuWlQweElpd2lZWE56YVdkdWJXVnVkRWxrSWpvaU1qYzRNVE5qTURFdFpUTmpNaTAwTkdJMExUbGxNVEF0TURsa1pXSTRZVEk1WXpOaUlpd2liR1ZoY201bGNrbGtJam9pTXpkaU4yRmpNRFF0TXpReU15MDBaR0kwTFRnMk1qQXRZVFkyTnpnM05qTmlOR1ppSWl3aWFXRjBJam94TnpFMU1qTTJNREF3ZlEuS21zV3pLNGN1cjN1WHRlLWhtYm1nZnBlbFMtQlVSZzUtdVo2Z0diZkJJcyIsImVtYWlsIjoid2lsbGNvdGVzZW1haWxAZ21haWwuY29tIiwiZXh0ZXJuYWxDdXN0b21lcklkIjoiMDB1cHFtazc0MTA2djdycHkyOTciLCJmaXJzdE5hbWUiOiJXaWxsIiwibGFzdE5hbWUiOiJDb3RlIiwicm9sZSI6InN0dWRlbnQiLCJyZWYxIjpudWxsLCJyZWYyIjpudWxsLCJyZWYzIjpudWxsLCJyZWY0IjoiMDB1cHFtazc0MTA2VjdyUHkyOTciLCJyZWY1IjpudWxsLCJyZWY2IjpudWxsLCJyZWY3IjpudWxsLCJyZWY4IjpudWxsLCJyZWY5IjpudWxsLCJyZWYxMCI6bnVsbCwiaWF0IjoxNzE1MjM2MDAwfQ.j_Ax-DeoEuZanRBBQfQHz63tXLc0H-R7SjSn66nvkiI

(this the URL from the button on MongoDB and the Document Model > Lesson 3 > Practice > Lab - But it’s the same for every “Lab”)
where I get this error:

Unexpected Application Error!

Failed to fetch dynamically imported module: https://static.instruqt.com/6880-98e181d1f-Production/public/PlayAppContainer-Bwh0I2aF.js

TypeError: Failed to fetch dynamically imported module: htt ps://static.instruqt.com/6880-98e181d1f-Production/public/PlayAppContainer-Bwh0I2aF.js

Thanks for the link @Will_Cote.

Can you also tell me which browser you are using?

I’ll reach out to our provider for this error but on my end, using Google Chrome, the lab loads correctly.

Thanks

@Will_Cote

Can you also try to clear your cache and then try to run the lab again? If you can have a screen record it will help.

The issue seems to be on our provider side and so, having a visual will help them investigate.

Thanks!

Thanks for the response. I was on chrome and after hearing that it was working for you I decided to try again and got it working!

The issue was with the uBlock Origin extension. I just disabled it and reloaded the page and it worked fine.

1 Like

Great.

Thanks for the feedback @code_r