Can't importing Data

Please, somobody helps me. I have mongo 4.0.4 and Ubuntu
I tried to import using this command:
mongorestore --drop --gzip --uri mongodb+srv://m220student:m220password@mflix-shard-0/ data

error parsing command line options: unknown option “uri”
try ‘mongorestore --help’ for more information

Also, I tried to use a command from my cluster:

mongorestore --host mflix-shard-0/,, --ssl --username m220student --password m220password --authenticationDatabase admin --drop --gzip data

Result: Failed: error connecting to db server: no reachable servers

I checked connection through mongo shell, It works.

How can I import data to my Cluster?

I download mongo3.6 and I have the same error

Hi @masha_dr,

Thank you for reaching out with this issue and providing info about your OS, mongo version and the error messages. This is super helpful.

It appears that you are using an older URI format to connect, when selecting a connection string in type chose the Short SRV connection string (For drivers compatible with MongoDB 3.6+) option.

This should give you the appropriate URI format

Does that resolve the issue?

Thank you for help. I resolved the issue installing MongoDB 3.6. I used different URI but it still didn’t work went back to the older version of Mongo.

Hi @masha_dr,

Just wanted to clarify, were you ale to import the data by switching to 3.6, or is that still a problem at the moment?

Kind regards,