Can't connect to Atlas cluster via IDE

Hello all,
I have been trying to run the following in the IDE Terminal
mongo “mongodb+srv://” --username m001-student
I used sample_airbnb and test as the dbname too. Furthermore, I also tried using “Sandbox” and “sandbox” in the above given connection string. Despite that, it was still prompting that I was unable to pass the test. (The connection string in the editor section was for my reference so I could easliy paste it in the IDE Terminal) Please find attached the screenshot of the same for your perusal. It would be really nice if anyone could help me figure out the same. mongodb
Thank you so much

Please revise the lesson where the IDE is presented.

You have entered the command in the file editing are rather than the terminal area.


After reading carefully the post I saw that the URI in the file editing area was simply for reference and that you have entered the command in the terminal area. We need the screenshot of the terminal area where you entered the mongo command.

Thank you for answering the query.
The following is the snippet of the terminal area where I entered the command and ran the tests again.

We do not see the command.

Check the data of your cluster, the connection uri, your cluster’s name must be Sandbox, the username must be 'm001-studen’t with ‘m001-mongodb-basics’ password

I’d say some of this parameters aren’t set correctly, you could try deleting and creating the cluster with the right set up

I had tried typing the command string. It wasn’t visible in the IDE Terminal. Is there some error in my command?

Thank you for replying. The data of the cluster, connection uri, username and the password are correct in my opinion. I can try deleting the cluster and creating once again.
Thank you

How can I know if you do not post a screenshot of the command you types?

I can confirm that the cluster is fine and that the data is loaded.

Don’t do that. Your cluster is fine.

I cannot actually type or paste my command in the terminal no matter how many times I try. What do I do?

So when you click on the Terminal 0 tab you are not able to enter the command?

Click on Terminal 0 tab and post screenshot.

Thank you for the help!
There was some issue at my end. I could access the IDE Lab and type in Terminal 0 after getting my issue resolved. I apologise for causing trouble.

Do not worry. No trouble caused.

1 Like

Hi @Harshita_Kaur,

Thanks for sharing your issue. We will update the lecture video on How to use the IDE.

And please feel free to ask any question or doubt that you have in your mind related to this course :slight_smile:

~ Shubham

Hi, can someone help me with my concern, I also encountered this issue. I use the correct connection string which is mongo “mongodb+srv://” --username m001-student, I also tried replacing the to test but it still occurs.

Hey @Gershon_Rivera
The mongo shell version which we need to use is 4.2 I believe.
Your connection string seems fine. How about clicking “Enter” key instead of “Run Test” after you change the version to 4.2? Mine worked like that.

When you type

mongo "<your connection string>" -u m001-student

And press Enter what’s the terminal output?

By now only Test results tab is shown

PS: consider opening a new post. This one has been solved already.

Hi, I think it’s seems fine to me now. Thank you for your reply! Appreciate it.