Cannot start vagrant

I am running on Windows 7 and downloaded/installed vagrant 1.9.6.
When I try to use either vagrant up or vagrant up --provision (with the 2 files being in the directory) I get

G:\m103>vagrant up --provision
Must redirect to new repository for old Vagrant versions

It just hangs there for a long time.

I think the latest version is 2.1.5.
So download the latest version and try again( i think that will work.

I can try that. Though my machine is Windows 7, so I thought that I needed 1.9.6…

Same here… although when I use ‘–provision’ doesn’t hang. See what I get…

I’m using Windows 7, SP1… which in the instructions says “NOTE If you are running Windows 7 Service pack 1, install Vagrant 1.9.6”… and I see the Vagrantfile having a condition right of the bat for versions lower than “2.0.0”… Must redirect to new repository for old Vagrant versions What should I do?

tried the newer version of vagrant but it requires an upgrade in powershell which requires a change in .net framework … ugh

Same here and no error, just hangs. I am not sure it is doing something

Hi Everyone,

Try with newer version of vagrant and virtualbox. On Windows, you might also need to upgrade powershell, enable virtualization in BIOS.

Let me know what issues you are still facing!


Any instructions on that?

  • Gil Braunstein

I cannot run it either, stuck on this:
vagrant up
The version of powershell currently installed on this host is less than
the required minimum version. Please upgrade the installed version of
powershell to the minimum required version and run the command again.

Installed version: 2

Minimum required version: 3

Yes. That is what I was getting to when I tried the latest version.

Then I looked at upgrading powershell and it required a newer .net framework which scared me :-).

I was going to try it on my personal laptop which is windows 10 and see where it goes…

  • Gil Braunstein
1 Like

Thanks Kanika, I’ll give it a try. I see you show as ‘Curriculum Support Engineer’, I’m pretty sure you might have seen something similar in the past w/Win 7 users… any suggestions from there? And also, if so, it’d be a good idea to update the documentation as well.

Hi Samuel_00552,

Here are some solutions from past discussions (These are all for Windows 7):

I used Win-7, Vagrant 1.9.6 and VirtualBox 5.2.16 at the beginning. The machine complained I need older version VirtualBox. Because I do not want to downgrade VirtualBox, I update Vagrant to 2.1.2. Meanwhile, I upgrade the windows PowerShell from 2 to 3. Everything worked.

i reinstall the last version 2.x.x and then run it, the error changed, so i launched vegrant --repair or the command mentioned in error message, and again i called the vegrant up , then it worked

According to “Chapter 0” notes, the users on Windows 7 SP1 were advised to install Vagrant 1.9.6. I am on Win7 and I did that but “vagrant up” command got stuck. I did some research and others experienced the same - and the solution was to upgrade the Windows PowerShell from pre-installed version 2.0 to at least 5.x+. I did that and it fixed the problem. Then - just for fun - I uninstalled Vagrant 1.9.6 and instead installed the latest Vagrant 2.1.5 and it worked just fine. Also, with Vagrant 2.1.5, I could use the latest available VirtualBox 5.2.18.

I hope it helps!

Surely, we will take a look and will update wherever necessary. Thank you for the note!


1 Like

Awesome!!! Appreciate you posting these previous comments. I think it’ll make us feel more comfortable doing the tweaks presented. I’m trying to install Vagrant’s latest version and see how it goes… I really don’t think PS/.Net should be a problem for me (PS 5.0 / .Net 4.7), BUT, I’ll let you know.

1 Like

I suppose to have all installed now but starting vagrant I have the following error:
…\m103\m103-vagrant-env>vagrant up --provision
Bringing machine ‘mongod-m103’ up with ‘virtualbox’ provider…
==> mongod-m103: Clearing any previously set network interfaces…
There was an error while executing VBoxManage, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: [“hostonlyif”, “create”]

Stderr: 0%…
Progress state: E_INVALIDARG
VBoxManage.exe: error: Failed to create the host-only adapter
VBoxManage.exe: error: Assertion failed: [!aInterfaceName.isEmpty()] at ‘F:\tind
erbox\win-5.2\src\VBox\Main\src-server\HostNetworkInterfaceImpl.cpp’ (76) in lon
g __cdecl HostNetworkInterface::init(class com::Bstr,class com::Bstr,class com::
Guid,enum __MIDL___MIDL_itf_VirtualBox_0000_0000_0038).
VBoxManage.exe: error: Please contact the product vendor!
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component HostNetworkI
nterfaceWrap, interface IHostNetworkInterface
VBoxManage.exe: error: Context: “enum RTEXITCODE __cdecl handleCreate(struct Han
dlerArg *)” at line 94 of file VBoxManageHostonly.cpp

Hi Robert_99127,

Try run the process as an administrator. I have found these solutions to be working so far:

Also, there are steps I found. This post is old, so look at the versions carefully for download(if needed):
Source: here

The steps to get it up and running are:

vagrant halt, uninstall vagrant and VB, if not latest

  1. install latest vagrant and latest virtual box, skip if already latest
  2. download
  3. Start the exe file as Administrator (right click, run as Administrator)
  4. cd to folder where vagrant is and vagrant up
  5. after vagrant completes booting close the window from the exe at point 3

With these stept the virtual machine will successfully boot and everything should work.

Yet if you had an old vagrant / VB like I did you will get a permission problem which can be fixed by:

  • if it is a regular vagrant machine open the Vagrantfile inside
    or if its puphpet
  • open #{dir}/puphpet/vagrant/Vagrantfile-local where #{dir}/ is your home vagrant folder
  • replace Vagrant.configure(‘2’) do |config| with config.ssh.insert_key = false

Let me know what works!


This is my system:
OS Name: Microsoft Windows 7 Professional
OS Version: 6.1.7601 Service Pack 1 Build 7601
OS Manufacturer: Microsoft Corporation
OS Configuration: Member Workstation
OS Build Type: Multiprocessor Free
Registered Owner: build
Registered Organization: Microsoft
As it is Win 7 I do not think I have Hyper-V at all anyway I tryied to find it and it is not on the list to turn on or off.
I used SecurAble to check hardware virtualization and it says “yes”
I cannot check the bios now and restarting my pc it takes 0.5h :confused:
Running command prompt as admin I have the following error:

vagrant up --provision
Bringing machine ‘mongod-m103’ up with ‘virtualbox’ provider…
There was an error while executing VBoxManage, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: [“sharedfolder”, “remove”, “d69829b1-f05e-45d1-95e6-89937db79f0f”, “–n
ame”, “shared”]

Stderr: VBoxManage.exe: error: Code E_FAIL (0x80004005) - Unspecified error (ext
ended info not available)
VBoxManage.exe: error: Context: “LockMachine(a->session, LockType_Write)” at lin
e 1091 of file VBoxManageMisc.cpp

Virtual Box version: 5.2.20
In Virtual Box I have machine: “mongod-m103” and I can start it and I have console with ubuntu 14.04.5 LTS vagrant-trusty-64 tty1
but asking me for a login…

I was able to get a little further. I downloaded powershell 3 and used the current version of vagrant.
when I run vagrant up it goes through quite a bit, but then it fails for virtualization.
I am looking in the BIOS but cannot figure out how to enable or disable it…I don’t see an option.

I am done! Thanks Kanika! As far as installation goes, I just installed the latest version of vagrant (I uninstalled the previous one before the new install). However, when I performed vagrant up I got an error, but within the same message I was suggested to run vagrant plugin repair, which I did, got a message ‘Installed plugins successfully repaired!’. After that, performed a vagrant up again, and it ran smoothly.

Don’t forget to submit a revision to the documentation!
Thanks again.

1 Like

Hi Robert_99127,

Credentials are:

username: vagrant
password: vagrant

These are default credentials for vagrant environment. If everything is running fine, try logging in and see if it works! In most cases, by looking at the error while doing vagrant up, you will see what next step is required.

As Samuel_00552 suggested, you can also try running vagrant plugin repair and see what it shows.

Thanks, Kanika

Hi Gil_11681,

Try these steps:

  • Type Turn Windows features on and off in search.

  • Enter

  • Place tick in Hyper-V box

  • Expand box by click on + sign

  • Ensure ticks in Hyper-V Management Tools & Hyper-V Platform

  • OK


Let me know if it works!