Cannot load the integrated IDE

I’ve tried all the solutions like closing all the tabs and windows of the browser, signing out of my account from everywhere, changed password and tried incognito, but the IDE Websocket connection errors out
“ide.tsx:120 WebSocket connection to ‘wss://’ failed: Error during WebSocket handshake: Unexpected response code: 403”
and after 4 failed retries to the Websocket connection, I’m shown an error saying:
You may be signed into another exercise in a different tab or window. Please close any additional open exercises and refresh this one.”.
Can someone guide me as to how to get this working?

I am not familiar with new IDE environment
May be other students who are using this can help you
In the first chapter it would have covered how to restart it

Do you have any active mongods running in foreground?
ps -ef|grep mong
If yes kill them
Usaully websocket errors 403 occur if you are not logged in but as per your comments you tried relogin

@Ramachandra_37567 I revisited the topics again just to see if there are recommendations about restarting, but couldn’t find any except. Closest was this article about the IDE: but that too doesn’t cover getting IDE working with this issue. There is no other mongod running. And yes I tried multiple re-logins, also tried different browsers.

Try, in this specific order…

Close all browsers , open a new window, delete cache + cookies + history, load university Home page and login (make sure it’s the Home page), navigate to the course and lab.

@007_jb this too doesn’t seem to work. I’ve cleared History, Cache other, site data, but still the IDE doesn’t load. I’ve tried the same in different browsers and even different laptop, just to see if any of the existing settings or extensions are blocking the connection. Doesn’t look like that.

The IDE now doesn’t load or it’s throwing up a 430 error? Share a screenshot.

@007_jb Here is the screenshot of the issue.

You may have been locked out. @Shubham_Ranjan will advise tomorrow.

@Shubham_Ranjan could you please look into this when you have some time?

Hi @Ashish_Dwivedi,

you can only have 1 tab open to a course at any time. Only one IDE session is permitted at a given time per student

The error message that you are seeing on your screen means that you might have another IDE based exercise open in another tab or window. If that’s the case then please close other tabs and windows.

Can you please check for that ?

~ Shubham

@Shubham_Ranjan as I mentioned in the comments above, I’ve closed all my tabs/windows, other browsers. Logged out of domain from all my browsers. And just to be sure to invalidate any active session also changed my password. But nothing works.

1 Like

Hi @Ashish_Dwivedi,

Sorry about that. I didn’t read it through. Let me sync with the relevant team for the resolution of the issue. I will get back to you shortly. Thanks for your patience.

~ Shubham

Hi @Ashish_Dwivedi,

We have fixed the issue. Can you please check and confirm that the issue has been resolved ?

~ Shubham

1 Like

Hi @Shubham_Ranjan thank you so much. I can access the IDE now. Could you please tell me what was the issue? Was it something that I did wrong just so that I can avoid that in the future?

Hi @Ashish_Dwivedi,

Let’s just say that your container was not destroyed properly and that’s why you were experiencing this issue. Don’t worry we are looking into it to figure out the exact cause.

Let us know if you have any other issue.

Happy Learning :slight_smile:

~ Shubham

1 Like

Hello Mr. Ranjan,

I am experiencing the same problem. Could you help me solve this issue too?

Thank you,
Sachin Parsa

Hi @Sachin_Parsa,

Thanks for surfacing this. Let me sync with the platform team. Please note that it may take 24-48 hours.

I will update you as soon as the issue gets resolved.

~ Shubham


I’m facing the same issue after I, mistakenly, refreshed the browser.

Thank you for your time.

Hi @Ricardo_Fadlallah,

It looks like that the issue has been resolved. Can you please confirm ?

~ Shubham

Indeed it has! Thank you!