Cannot Install M312 envoronment


Can you please advice the version of which combination of virtualbox and vagrant for this lab M312 works?
I have been unable to to successfully get the lab installed successfully on my Windows machine. The details
of my machine is shown below:-

OS Name = Microsoft Windows 10 Enterprise
Version = 10.0.18363 Build 18363
System Type = x64-based PC

Vagrant 2.2.10
Virtual Box 6.1.14

The error messages :-

m312: + install_mongod
m312: + echo ‘Install MongoDB Enterprise’
m312: + wget -q -O mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2.tgz ‘
m312: + tar xvf mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2.tgz
m312: mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2/LICENSE.txt
m312: mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2/README
m312: mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2/THIRD-PARTY-NOTICES
m312: mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2/MPL-2
m312: mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2/snmp/MONGOD-MIB.txt
m312: mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2/snmp/MONGODBINC-MIB.txt
m312: mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2/snmp/mongod.conf.master
m312: mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2/snmp/mongod.conf.subagent
m312: mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2/snmp/README-snmp.txt
m312: mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2/bin/mongodump
m312: mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2/bin/mongorestore
m312: mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2/bin/mongoexport
m312: mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2/bin/mongoimport
m312: mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2/bin/mongostat
m312: mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2/bin/mongotop
m312: mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2/bin/bsondump
m312: mongodb-linux-x86_64-enterprise-ubuntu1404-3.4.2/bin/mongofiles
m312: tar:
m312: Skipping to next header
m312: tar:
m312: A lone zero block at 186403
m312: tar: Exiting with failure status due to previous errors
The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.
PS C:\Users\oogunfowora\m312-vagrant-env>

Also, I cannot install the nodes-vagrant-env environment, I also get the following error messages
Copy iso file C:\Program Files\Oracle\VirtualBox\VBoxGuestAdditions.iso into the box /tmp/VBoxGuestAdditions.iso
Mounting Virtualbox Guest Additions ISO to: /mnt
mount: block device /tmp/VBoxGuestAdditions.iso is write-protected, mounting read-only
Installing Virtualbox Guest Additions 6.1.14 - guest version is 4.3.40
Verifying archive integrity…Error in MD5 checksums: bf7146dfffb4df4f227dd5fb600aa4c5 is different from c869d5d5729ff7863752dbafc6e7e9c5
An error occurred during installation of VirtualBox Guest Additions 6.1.14. Some functionality may not work as intended.
In most cases it is OK that the “Window System drivers” installation failed.
vboxadd: unrecognized service
Unmounting Virtualbox Guest Additions ISO from: /mnt
==> m1: Checking for guest additions in VM…
m1: The guest additions on this VM do not match the installed version of
m1: VirtualBox! In most cases this is fine, but in rare cases it can
m1: prevent things such as shared folders from working properly. If you see
m1: shared folder errors, please make sure the guest additions within the
m1: virtual machine match the version of VirtualBox you have installed on
m1: your host and reload your VM.
m1: Guest Additions Version: 4.3.40
m1: VirtualBox Version: 6.1
==> m1: Setting hostname…
==> m1: Configuring and enabling network interfaces…
==> m1: Mounting shared folders…
m1: /shared => C:/Users/oogunfowora/nodes-vagrant-env/shared
Vagrant was unable to mount VirtualBox shared folders. This is usually
because the filesystem “vboxsf” is not available. This filesystem is
made available via the VirtualBox Guest Additions and kernel module.
Please verify that these guest additions are properly installed in the
guest. This is not a bug in Vagrant and is usually caused by a faulty
Vagrant box. For context, the command attempted was:

mount -t vboxsf -o uid=1000,gid=1000 shared /shared

The error output from the command was:

mount: unknown filesystem type ‘vboxsf’

Please note I have not been able to install any of the provided environments on my Windows machine.

They would have mentioned requirements in the installation steps
From university course page you can see system requirements

Suggest you to search our forum threads
Yes sometimes version conflicts will be there
Do you have any other VM’s?
Have you tried vbgust plugin step

Hi, the thing is I have searched the forum threads and cannot find anything to answer my question. The thing is I have access to 3 machines, 2 Windows 10’s and a MacBook Pro.

The Lab environments install and work on the MacBook Pro, but not on the Windows machines.

Yes I have tried the vbguest plugin step