Cannot install Compass on Linux Mint 19.1

Hi there,

I downloaded the compass stable version 1.20.1 for Ubuntu (14.01+) but when installing it with the command with the command dpkg, I get the following error:

dpkg-deb: error: ‘mongodb-compass_1.20.1_amd64.deb’ is not a Debian format archive
dpkg: error processing archive mongodb-compass_1.20.1_amd64.deb (–install):
dpkg-deb --control subprocess returned error exit status 2
Errors were encountered while processing:

Does anyone have an idea on what may be going wrong ?

Thank you in advance for your help -

May be downloaded file is not ok?

Having issues installing mongoDb Compass in Linux Mint

Many thanks for your answer.

I went to the link and indeed the issue seems to be the same. Nevertheless, it’s not clearly stated how the problem was solved and I asked the author of the topic to detail how he fixed it.

In the meantime if someone else has an idea, he is welcome !

Hi @Moncef_29335,

You are getting this error because may be your downloaded package is broken or sth.

Please have a look at this page for downloading and installing compass on your system.

Hope it helps!

Shubham Ranjan
Curriculum Support Engineer


I have the same problem with the same EM. I tried using the page you linked us to, but it makes no difference. I have installed ubuntu 20.04.
I copy the string, go through all the steps, it won’t work. I also tried downloading it from the page that pops up when I hit ‘connect to mflix’ in atlas. The same result. I noticed I downloaded two files : mongodb-compass_1.26.0_amd64.deb and mongodb-compass_1.26.0_amd64.deb.part. I could not install the first file but could install the second. But when installed, I still don’t know how I’m to open (the command: mongodb-compass, doesn’t work, the computer doesn’t recognize it) . I don’t know what the difference is between the two files. I removed everything and now I don’t know what to do.

Thank you and greets,
Karin Meersman

Welcome to the community Karin

that most likely means the browser didn’t complete the download. re-download the deb file.
Or, from the terminal run



sudo dpkg -i mongodb-compass_1.26.0_amd64.deb

Good luck

1 Like

Thank you, it worked!
I downloaded it again and this time I waited. Compass is there now.


1 Like

Hi @Karin_Meersman, I am glad that you got it working. In case you have any doubts, please feel free to reach out.

Thanks. Regards.
Sourabh Bagrecha,
Curriculum Services Engineer.