Cannot connect to the M121 course Atlas Cluster

Typed the whole command as given in the tutorial, the command gets executed but connection doesn’t happen.

It is taking too long , like 1 hour to execute the command but still not getting connected to M121 course Atlas Cluster.

From what I see you typed ‘mongo’ which start a mongo shell connected to your local mongod. And from the mongo shell you type the url of the atlas cluster with other parameters.

The url of the cluster and the other arguments need to be on the mongo command.

Basically you typed:

mongodb:// … --norc

but what you have to do is:

mongo mongodb:// … --norc

In other words mongodb: and other arguments are arguments of the mongo command, not a command to enter in the mongo shell.

The three little dots that you see is a prompt from the mongo shell telling that it awaits for you to terminate the command. But the command you entered at the mongo shell prompt 'MongoDB Enterprise > ’ is not a mongo shell command it is the argument that you give to mongo.

1 Like

Great. It worked.