Cannot Connect to Compass

Hello, I downloaded Compass v. 1.15.4 (Stable) Windows Edition on my Windows 10 Desktop. I am following the instructions on the chapter 1 video, “Connecting to MongoDB Using Compass” and am receiving the following warning:

“An error occurred while loading navigation: ‘not master and slaveOk=false’: It is recommended to change your read preference in the connection dialog to Primary Preferred or Secondary Preferred or provide a replica set name for a full topology connection.”

I wanted to check what might be causing this, and what steps I could take to resolve this. My configuration is as below. Thank you.

Shouldn’t the Read Preference be Primary Preferred
See my screenshot in the post here: Not able to connect to the cluster in compass

Hi Ryan_63094,

Please change the read preference to “Primary Preferred”. If you are still unable to connect, I would like you to go through this post.

Let me know if you still face any issues.

Thanks, Kanika


I got the same error initially. Please retry read preference with “Primary Preferred”, It should work.

I had the same problem, I checked the connection parameters according to this , closed the connection and application. I also killed the processes that were still running from mongodb-compass and re-started. Now it is working. Thanks!

1 Like

I always had “Could not connect to MongoDB on the provided host and port” with compass. When i use tracert, it gives me ( And Ican’t continue with compass.


If you seeing something like this, means you can access the host.

Try telnet 27017 from the command line.
It should show something like :slight_smile:

`Connected to`

If you are able to see the above message, please check the parameters again if have missed some space or something. You must have already gone through, but if you can take a look again here

Let me know if it works!


1 Like

thank you. I take a mobil connect network carte and it works now.

Le mar. 16 oct. 2018 à 13:04, Kanika Singla a écrit :

1 Like