Cannot connect to atlas cluster

Ive tried a few times to connet to the atlas server for this course and no matter what network im on (Corporate or open, at home etc) i seem to get the following message :
err: couldn’t connect to server, connection attempt failed: SSLHandshakeFailed: QueryContextAttributes for connection info failed with-2146893055 :

Im using the expression below thats listed on the course.

mongo “mongodb://,,” --authenticationDatabase admin --ssl -u m121 -p aggregations --norc

@ Thomas_75980

What OS and version are you running? And, if you can, would you try the following command from your command line just to validate that you can reach the server?


remove extra " before this key

Im currently running windows 10 latest update and the ping command gets replies no problem .
It may also be worth mentionting that im also runnignthe shell version 4.0.2

@Niss333 That didnt work unfortunately

This batch works for me on windows 10:

cd “C:\Program Files\MongoDB\Server\4.0\bin”
mongo.exe mongodb://,, --authenticationDatabase admin --ssl -u m121 -p aggregations --norc

@Niss333 hmm weird that doesnt seem to work either, ill try building another machine to see if its a problem with the laptop

found my problem
apparently the atlas cluster can only be access from a v3 shell. i was attempting to connect from the latest version …

1 Like

@ Thomas_75980

OK. Glad you solved it and good to know for the future. Post back here if you continue to have problems. Good luck.