Cannot connect by using Mongo Shell

Up to now, courses are great and by following them it is possible to get as much info and knowledge as possible but even all great courses, I couldn’t find the way to connect given links by using Mongo Shell.

See Chapter 0: Introduction and Aggregation Concepts - Atlas Requirement, the command is right there.

Thank you very much, but my problem is not that I couldn’t find the command, I have the command but whenever I use the command shell does not give any response and does not start, just waits. I used the command in compass, it works well, I used the command in online IDE from M001 again it worked well but whenever I try on Mongo Shell does not respond and even does not give any db when I write show dbs

Post a screenshot of the issue.

Just having … and nothing else

When you have something like

MongoDB Entreprise >

it is the mongo shell. You are already in the shell. You have to exit to return to your windows prompt and type the command exactly like shown in the lesson.

I tried both, also tried in git bash no change. I do not understand what happened but I think I am missing something about this subject.

The command, exactly as I copied it from the lesson is:

mongo "mongodb://,," --authenticationDatabase admin --ssl -u m121 -p aggregations --norc

But you seem to first type mongo [ENTER] and then you enter the URI mongodb://,," --authenticationDatabase admin --ssl -u m121 -p aggregations --norc at the mongo prompt.

The command mongo and its argument (the URI) is one line.

1 Like

Yes, you are right about the link. But In the end I found how to start it. With you advise, I tried, did not work but your advise lead to the solution. The steps I followed are as follows :

1- In Git Bash, I entered the directory of mongo shell (cd c:/directoryofMongoShel/bin)
2- The I wrote start and the command : mongo “mongodb://,,” --authenticationDatabase admin --ssl -u m121 -p aggregations --norc
Thats is :
$ start mongo “mongodb://,,” --authenticationDatabase admin --ssl -u m121 -p aggregations --norc

and hence it entered to the Cluster0-shard-0:Primary

Thank you very much for your support.