Can’t push Realm app when natural pluralization is false

Hello,

I’m currently developing a CI/CD Pipeline for a Realm application and have come across a problem with the Realm CLI that I can’t seem to figure out.

The CLI won’t let me push a new application if the GraphQL configuration (root/graphql/config.json) defines the natural pluralization as false.

So, when the config.json looks like this:

{
  "use_natural_pluralization": false
}

And I push the application with:

realm-cli push --project <Atlas ProjectID>

I get the following error:

push failed: cannot update graphql config field "use_natural_pluralization" 

I understand that this setting cannot be turned off once it is enabled. But science I am creating a new application, I don’t understand why can’t I disable the setting initially.

I have tried multiple variations of the file to work around the problem:

  • Setting the value to false throws the previously mentioned error
  • Empty braces (no key value pair) → natural pluralization enabled
  • Empty file (no content, not even curly brackets) → n.p. Is enabled
  • No file (deleted it before the push) → n.p is enabled.

Because the setting can’t be turned off once it is enabled, all these methods won’t work for us.

I noticed, that when creating a new App via the Realm Web UI, the setting seems to be enabled by default as well.

So, is natural pluralization now the standard and there is no way around it? I would really like to avoid reworking our entire schema, so if there is a way to operate without it, I would be delighted.

Regards.

Sam

4 Likes