Can not connect to the class cluster

I have been trying to connect to the m001 class cluster for the past few days but I keep getting this message after the connection is established An error occurred while loading navigation: ‘not master and slaveOk=false’: It is recommended to change your read preference in the connection dialog to Primary Preferred or Secondary Preferred or provide a replica set name for a full topology connection.

Hi Hamza_67493,

Please take a look at this post.

Let me know if it works!


@Kanika The server was overloaded I think. After trying multiple times I was able to establish a connection.

1 Like

I have been trying since 2 days to connect to the Atlas class cluster but have the same error.

I still cannot connect. I tried uninstalling and reinstalling Compass.

Hi Sumaiya_09928,

I am sorry that you are having problems with Compass. Here is the post that I want you to check first and try debugging your problem.

Try this from your command terminal:


If you are unable to ping then your system might be blocking the request. You need to contact your IT administrator. Make sure your port 27017 is free to use.

Let me know if I can help!


Hey Sumaiya_09928

Go to Link

Follow Instructions

1 Like