Basic Reads follow-along - Strange output in Jupyter notebook

Hi folks,
I haven’t had problems hooking up the mongo shell to my server. After running all the installs “python” works as expected.

I then went to follow along the Basic reads lecture loading in the our_first_read notebook. After pointing to my server, I started running commands.

import pymongo
uri = “mongodb+srv://”
client = pymongo.MongoClient(uri)
m220 = client.m220
movies = m220.movies

This gave no output. Not that unusual. I then added and ran:
Collection(Database(MongoClient(host=[‘’, ‘’, ‘’], document_class=dict, tz_aware=False, connect=True, authsource=‘admin’, replicaset=‘mflix-shard-0’, ssl=True), ‘m220’), ‘movies’)

Promising. But now when I went to run:
in the video you get the json output. But in my notebook there is not output. The input counter goes up, but that is it.

I then tried:
movies.find( { “cast”: “Salma Hayek” } )
and got:
<pymongo.cursor.Cursor at 0x104fc22e8>
like in the video. So it it is kind of working.

Following along the video tried:
movies.find( { “cast”: “Salma Hayek” } ).count()
instead of 29 being returned, I get this warning:
/Users/Spur/anaconda3/lib/python3.6/site-packages/ DeprecationWarning: count is deprecated. Use Collection.count_documents instead.
“”"Entry point for launching an IPython kernel.

Any ideas? Thanks,