AWS sdk in Atlas functions not working

AWS sdk does not seem to work with atlas functions. I tried to use version 2.737.0 as suggested by @Drew_DiPalma in this post: Link.

I’m always getting this error when trying to deploy:
Bildschirm­foto 2023-01-31 um 01.14.31

This is what’s in my package.json:

  "name": "functions",
  "version": "1.0.0",
  "main": "index.js",
  "license": "private",
  "engines": {
    "node": ">=10.17.0 <=10.18.2"
  "scripts": {
    "test": "jest"
  "dependencies": {
    "stripe": "10.17.0",
    "aws-sdk": "2.737.0"
  "devDependencies": {
    "jest": "27"

I tried so many different versions. This is so very frustrating as I’ve been spending too much time on it. Currently, I’m halfway into implementing my calls using REST API with manual request signing but it’s just so unnecessary since there is a perfectly good sdk to use. With firebase, this is just working like a charm.

Is there any way to use the sdk with atlas functions?

Hi @Daniel_Weiss – Apologies, but we were having an issue with saving dependencies within Functions for a few hours last night that this is likely related to. Are you able to re-try the AWS SDK today?

You can find specific timing of this issue on our status page FYI.

Thank you very much for your quick reply. I tried it again and it’s working like a charm now :slight_smile:

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.