Atlas shell on linux

I am unable to configure atlas shell on linux. Is there a tutorial I can follow?

Hi @Felipe_62775,

There is very detailed instructions in README file, also in M001: MongoDB Basics course.

Please let me know in which step you need help.


I tried to do what is shown in the introductory course, but when I download the file and try to install it nothing happens. I found a way to install on ubuntu 18.04.

After installing it just use the following command to activate mongodb in the terminal.

sudo service mongod start

Looking at the status of the mongo after this with the command

sudo service mongod status

I have this

when trying to connect using the command provided by Atlas Cluster

In this case, it is the command:

mongo “mongodb+srv://” --username m220student

I get the following error

I do not know what I should do to resolve this error. I would like to know what I can do to connect to the mongodb.

when I use the command

mongo --version


I await some suggestions.

You are mistaking 2 things. You are starting a mongod server with sudo service … and yet you try to connect to an Atlas server with Compass. You do not need to do sudo service … to connect to Atlas. However you must whitelist your IP address so that the Atlas firewall let you connect to your cluster.

I have released the access to for any ip, as shown below.

I just showed the activation of mongo server to show that it was installed.

I didn’t try to connect with Compass, I went in this first option.

if you look at the picture of my old post is different if i click to connect to the compass. That is the figure below.

What command do I have to use to connect?

If you have Compass you start Compass.

  1. Connect with Mongo Shell

Then use the connection string in .ini file and you will be good to go.