Anaconda Issue mflix M220P Connection Failed

(base) Random-MacBook:mflix-python random$ conda create --name mflix
Collecting package metadata (current_repodata.json): done
Solving environment: done

CondaHTTPError: HTTP 000 CONNECTION FAILED for url <http s://>
Elapsed: -

An HTTP error occurred when trying to retrieve this URL.
HTTP errors are often intermittent, and a simple retry will get you on your way.

If your current network has blocked, please file
a support request with your network engineering team.

(base) Random-MacBook:mflix-python random$

This looks unfortunately very broken.

" Anaconda is a distribution of the Python and R programming languages for scientific computing (data science, machine learning applications, large-scale data processing, predictive analytics, etc.), that aims to simplify package management and deployment."

So two questions:
How to fix?
Realistically, how much of the course does this totally cripple (for me)?

I should mention I have no firewall, and using wget on the file in question results in the same failure.


Hi @Alexander_Boese - welcome to the forums!

I’ve just 'wget’ted that URL ( and it worked for me.

I’d suggest trying it again as it might just have been a temporary networking issue.

Otherwise, you can alternatively try to install the necessary software using just Python’s pip and virtualenvs for the virtual environment. This will allow you to continue the course if there are still installation issues with Conda.

Kindest regards,

Thanks. I tried wget myself earlier without success. Hopefully just a temporary issue, though it has been several hours.

Hi @Alexander_Boese

Did the issue resolve itself and were you able to install Conda?

Kindest regards,

Never resolved. Used virtual envs in python instead, which worked fine. I would have immediately tried that instead, but it was listed on the bottom of the page and I normally work through labs one step at a time without reading ahead.

Hi @Alexander_Boese

Sorry to hear that there was no resolution with the Conda environment but I am happy that the virtual environments in Python have allowed you to continue. We’ll investigate this further to see what might be the root cause.

Kindest regards,

I tend to blame the OS (Mac OS X) for oddities. It’s certainly possible that I had something that needed patching, but the documentation was less than conclusive, and without using a firewall, I don’t know what else was going on. I do remember reading about some overriding filter or rules that run without even the firewall being on in Mac OS X, but I’ve not had to investigate issues on that from anything else.

wget of that works now, so maybe the fix I had to do to get mongo shell running was related.

There was some obscure thread that mentioned brew needed to install some base packages, which I’m guessing were maybe installed but not brew managed. I don’t know - just messed around with install/reinstall on some related brew dependencies and the mongo shell install suddenly was able to work following a restart. So maybe related…

Hi @Alexander_Boese

I’m sorry to hear it involved some much obscure setup steps, it really isn’t normally meant to be as complex and hopefully, you won’t hit any more problems.

Good luck with M220P and if you do have any questions or issues with anything in the course, please do raise another post so we can work to answer them.

Kindest regards,