(Ana)conda n00b -- what am I doing wrong?

  1. Downloaded mflix code and extracted to directory D:\M220P
  2. Installed Anaconda as per instructions
  3. In command shell, changed to D:\M220P folder
  4. Attempting to create conda environment, but getting an error: too few arguments

Results below
Directory of D:\M220P

18/10/2018  12:09    <DIR>          .
18/10/2018  12:09    <DIR>          ..
18/10/2018  12:09    <DIR>          data
18/10/2018  12:09               417 dotini_unix
18/10/2018  12:09               428 dotini_win
18/10/2018  12:09    <DIR>          mflix
18/10/2018  12:09    <DIR>          migrations
18/10/2018  12:09    <DIR>          notebooks
18/10/2018  12:09            10,742 README.rst
18/10/2018  12:09               245 requirements.txt
18/10/2018  12:09               379 run.py
18/10/2018  12:09    <DIR>          tests
               5 File(s)         12,211 bytes
               7 Dir(s)  303,073,300,480 bytes free

D:\M220P>conda create --name mflix
Error: too few arguments, must supply command line package specs or --file

You can specify one or more default packages to install when creating
an environment.  Doing so allows you to call conda create without
explicitly providing any package names.

To set the provided packages, call conda config like this:

    conda config --add create_default_packages PACKAGE_NAME


Hello James_11323,

Sorry about the late reply.

Have you tried adding a Python version to the command? I.e.:

conda create --name mflix python=3.6

Let me know if this helps.


I hadn’t tried that. Just created ‘mflix’ environment from the Anaconda UI. Seemed to work.

Including the python version might have resolved an issue with one of the Jupyter notebooks that used 3.6 specific

print (f “some string {variable} with formatting” )

but I just hacked it back to

print ( “some string { } with formatting”.format (variable))