An error occurred while loading navigation: 'not master and slaveOk=false'


I have downloaded MongoDB Compass (not community version) and I cannot enter the DB.

Here is the connect form:

Here is the error:

Here are Ping and Tracert requests:

Community compass works OK, but it does not have Schema Explorer.

I would be grateful for any assistance.

Please ensure the following:

  1. Make sure it is MongoDB Compass Stable version i.e 1.15.4

  2. Ensure that you have written all the parameter names correctly. No whitespace should be trailing in the cluster name.

  3. Try to switch off SRV Record (incase it was switched on)

If the above two points don’t resolve your issue, then quit Compass, klll The MongoDB GUI process and start Compass. Ensure both the above points are met and connect.

If the above step still does not solve your problem, then please follow the above point of quitting Compass, killing the process and re-install Compass.

Let me know if it helps!


1 Like

Hi @Kanika !

For some reason I could successfully enter the DB with the same config after I had killed the GUI process :slight_smile:


1 Like

Good to know :slight_smile: Good luck!


Hi, I’m suffering a big delay to connect to the training cluster. My Compass software is since a quarter thinking and it has not shown the training databases. I’ve tested the URL to check the firewall and it worked fine.
Below you can see the screen I’m viewing since some minutes. Can anyone help me?

By the way, I have the latest Compass version, I’ve filled correctly the parameters and I’ve set off the SRV Record.

Hi Ignacio,

Have your tried everything mentioned in this thread: About the Chapter 1: Compass Connection ?

If you have, I would recommend restart Compass, try login again and let me know if the issue is still there.

Thanks, Kanika

Thanks kanikasingla, it worked… I continue with the training…

1 Like

, klll The MongoDB GUI process and start Compass. Ensure both the above points are met and connect.

can you explain above broadly

1 Like

Hi vinayyalla,

It simply means restart Compass.

Quit the application. If you are on Windows, go to Task Manager and Quit the process.
If you are on Mac, Right click on the application and Quit.

Then start again Compass.