About chapter 1 of M001: MongoDB Basics Course

Hi,

In the last lab of chapter 1 ( “Lab: Connect to your Atlas Cluster”) after entering connection string I cannot enter the password. I cannot enter anything in that given space it means cannot type any value here. But without type anything if I enter that empty space it give me this kind of error.

How I solve this problem. I spent lot of time to fix this issue. But still I cannot solve this problem. What should I do ?

Hi @Ashini_Pushmika,

Welcome to the MongoDB Community Forums!

After pasting the connection string, hit the enter/return button input the password ( the blinking cursor will be invisible, so don't worry) it is normal and it is done to hide the password, then press enter/return button to connect to your Atlas cloud cluster.

In case of any issues, feel free to reach out :sparkles:

Thanks,
Kushagra

I tried again. But still I have the same issue. I cannot pass the password in that given space. When I type the password I am not allowed to type anything in that given space provided.

Hey @Ashini_Pushmika,

Your input is getting recorded by the IDE, but nothing will appear on screen, neither any asterisks nor bullets as I have mentioned earlier in my last response. So, just type it and hit return/enter.

typing-password-into-terminal

Thanks,
Kushagra

1 Like

Okay Thank you… I typed it and entered. But the above error was still getting.

And in my sandbox mongo shell version is displayed as “mongosh”. when I type and enter this connection string, I am getting an error.
So, I changed the mongo shell version into “4.4” and enter this connection string, then it was successful. But after entering the password I am getting above error.



Have you whitelisted your IP? or allow access from anywhere

I gave my IP address

Try 0.0.0.0 allow from anywhere

1 Like

It s also not working

What error are you getting

I can connect to your cluster without any issues
Earlier it was not working but may be after changing allow access from anywhere it is working

MongoDB Enterprise atlas-129lh6-shard-0:PRIMARY> db
test
MongoDB Enterprise atlas-129lh6-shard-0:PRIMARY> show dbs
admin 0.000GB
local 4.603GB

1 Like

Yes. I tried again. Now It s working. Thank you so much

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.